Ionic Error: EXDEV, cross-device link not permitted

今天當我嘗試在我的 Ionic Framework Project 安裝 cordova plugin 時出現了以下的錯誤信息..

<code class="language-text" data-lang="text"><a href="https://github.com/phonegap-build/PushPlugin.git" target="_blank">cordova plugin add https://github.com/phonegap-build/PushPlugin.git</a></code>

Error: EXDEV, cross-device link not permitted
Ionic Error: EXDEV, cross-device link not permitted
做了一會research 之後發現..
應該是 電腦上安裝了的 Corodova 版本有問題..
所以只需要 安裝舊一些的版本便可以解決這個問題

解決方法
command prompt 上執行以下指令去安裝 指定版本的 cordova

npm install -g cordova@5.0.0

npm install -g cordova@ version
安裝完了再次嘗試安裝 這個cordova plugin..
e.g. Ionic / Cordova Push Notification plugin

cordova plugin add https://github.com/phonegap-build/PushPlugin.git

Able to install Cordova plugin

成功安裝

Hope you find it useful

Leave a Reply