Ubuntu 14.04 – This failure might be due to the use of legacy binary “node”

今日嘗試在Ubuntu 安裝Yemon 去在Ubuntu Server 14.04 上測試
Asp.net Core的 setup

sudo npm install -g yo

但是出現了以下的錯誤信息
This failure might be due to the use of legacy binary ‘node’
This failure might be due to the use of legacy binary "node"
做完一會research之後發現現來是 Ubuntu 14.04的問題
他的node 是用 nodejs來執行的

解決方法 十分簡單..我們只需要建立一個symbolink 來把 nodenodejs 連接在一起..
令到在執行 node時..實際是在執行 nodejs..便可以了

sudo ln -s /usr/bin/nodejs /usr/bin/node

Hope you find it useful

Leave a Reply