‘const’ is available in ES6 (use ‘esversion: 6’) or Mozilla JS extensions (use moz). JSHints JSCS

搭飛機訓唔著係一件十分痛苦的事..
幸好..可以給我一些時間去tidy up自己之前hackathon 的Code
但在執行gulp 的JSCS 時出現以下的Warning.

‘const’ is available in ES6 (use ‘esversion: 6’) or Mozilla JS extensions (use moz).
'const' is available in ES6 (use 'esversion: 6') or Mozilla JS extensions (use moz)

在機上不能上網..今天終於有時間去research下怎樣解決

解決方法十分簡單..
只要在 .js 檔案的上方 加入下comment便可以不再顯示這些Warning
jshints esversion 6 issue fixed

/*jshint esversion: 6 */

Hope you find it useful

Leave a Reply