ESLint couldn’t find the plugin (when install dependencies using yarn)

今日嘗試用 command line (CLI) 執行 ESLint 時出現了以下的錯誤信息

# eslint command
eslint ./src

Error: Cannot find module 'eslint-config-airbnb'

仔細看他其實是在找npm install 的 module 的 folder
“c:\user\chi\AppData\Roaming\npm\node_modules”
但我是用 yarn install的所以 是使用錯了folder
解決方法十分簡單
我們只要使用 yarn 執行便可

 yarn eslint ./src

Hope you find it useful

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.